7-2 到底有多二

7-2 到底有多二
一个整数“犯二的程度”定义为该数字中包含2的个数与其位数的比值。如果这个数是负数,则程度增加0.5倍;如果还是个偶数,则再增加1倍。例如数字-13142223336是个11位数,其中有3个2,并且是负数,也是偶数,则它的犯二程度计算为:3/11×1.5×2×100%,约为81.82%。本题就请你计算一个给定整数到底有多二。

输入格式:
输入第一行给出一个不超过50位的整数N。

输出格式:
在一行中输出N犯二的程度,保留小数点后两位。

输入样例:
-13142223336
输出样例:
81.82%

#include<iostream>
#include<cstring>
#include <iomanip>
using namespace std; 

int main()
{
    char a[100];
    int i = 0, t = 0, count = 0, fu = 0;
    float ans;

    cin.getline(a,100);
    if(a[0] == '-')
    {
         i = 1;
        fu = 1;	       //负数开关
    }
    for(;i < strlen(a);i++)	//统计位数和2的个数 
	{
		count++;      //统计位数
		if(a[i] == '2') t++;      //2的个数
	}
    if((a[i-1])%2 == 0)		//最后一位数为偶数 
	{
		ans = (double)t/(double)count * 2 * 100;
		if(fu) ans *= 1.5;
		cout<<fixed<<setprecision(2) << ans << "%";
	}
    else						//最后一位数为奇数 
	{
		ans = (double)t/(double)count * 100;
		if(fu) ans *= 1.5;
		cout<<fixed<<setprecision(2) << ans << "%"; 
	}
	return 0;
}
发布了12 篇原创文章 · 获赞 0 · 访问量 1219

猜你喜欢

转载自blog.csdn.net/weixin_45644335/article/details/102956275
7-2
今日推荐