1148 Werewolf - Simple Version (20分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<Msuch that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution
#include<iostream>

#include<vector>
#include<cmath>
#include<unordered_map>
#include<vector>
using namespace std;




int main(){
    int n;
    cin >> n;
    
    vector<int> werewolf(n+1);
    for(int i = 1; i <= n; i++){

        scanf("%d", &werewolf[i]);
        
 
    }

    for(int i = 1; i < werewolf.size(); i++){

        for(int j = i + 1; j < werewolf.size(); j++){
           
            int people_cnt = 0, wolf_cnt = 0;
            bool flag = true;

            for(int z = 1; z < werewolf.size(); z++){
                if(!flag)
                    break;
                if(z == i || z == j){//wolf

                    if(werewolf[z] > 0 && (werewolf[z] == i || werewolf[z] == j))
                        wolf_cnt++;
                    if(werewolf[z] < 0 && (-werewolf[z] != i && -werewolf[z] != j))
                        wolf_cnt++;
                    if(wolf_cnt > 1)
                        flag = false;
                }else{//people

                    if(werewolf[z] > 0 && (werewolf[z] == i || werewolf[z] == j))
                        people_cnt++;
                    if(werewolf[z] < 0 && (-werewolf[z] != i && -werewolf[z] != j))
                        people_cnt++;

                    if(people_cnt > 1)
                        flag = false;
                }
            

            }
            if(people_cnt == 1 && wolf_cnt == 1){

                cout << i << " " << j << endl;
                return 0;


            }

            
            }
            
            

           
        }
        
     
    
    cout << "No Solution" << endl;
            


    return 0;
}
发布了32 篇原创文章 · 获赞 0 · 访问量 440

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104054374