1148 Werewolf - Simple Version (暴力遍历)

1148 Werewolf - Simple Version (20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

思路:

1、i从0到n-1,j从i到n,选取两个作为狼人,然后k从0到n检测每个人说话的真假,如果是谎话,则存到一个ArrayList中,最后判断满足不满足条件,即一个狼说谎,一个人说谎。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;

public class Main {

	public static void main(String[] args) throws IOException {
		// TODO Auto-generated method stub
		BufferedReader in= new BufferedReader(new InputStreamReader(System.in));
		String str = in.readLine();
		int n = Integer.parseInt(str);
		int[] a = new int[n+1];
		for(int i=1;i<n+1;i++) {
			str = in.readLine();
			a[i] = Integer.parseInt(str);
		}
		int [] real = new int[n+1];
		ArrayList<Integer> al = new ArrayList<>();
		int flag=0;
		one:for(int i=1;i<n;i++) {
			real[i]=1;
			for(int j=i+1;j<n+1;j++) {
				real[j]=1;
				for(int k=1;k<n+1;k++) {
					if(a[k]<0&&real[-a[k]]==0||a[k]>0&&real[a[k]]==1)
						al.add(k);
				}
				if(al.size()==2&&(al.contains(i)!=al.contains(j))) {
					System.out.println(i+" "+j);
					flag=1;
					break one;
				}
				real[j]=0;
				al.clear();
			}
			real[i]=0;
		}
		
		if(flag==0)
			System.out.println("No Solution");
		
		
	}

}

猜你喜欢

转载自blog.csdn.net/weixin_38902950/article/details/88055124