PAT (Advanced Level) 1148 Werewolf - Simple Version (20 分)

版权声明:转载请附链接 https://blog.csdn.net/isunLt/article/details/87896687

1148 Werewolf - Simple Version (20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

    player #1 said: "Player #2 is a werewolf.";
    player #2 said: "Player #3 is a human.";
    player #3 said: "Player #4 is a werewolf.";
    player #4 said: "Player #5 is a human."; and
    player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?
Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

Code:

#include <iostream>
#include <vector>
#pragma warning(disable:4996)
using namespace std;
int main()
{
	int n; scanf("%d", &n);
	vector<int> vec(n + 1);
	for (int i = 1; i < vec.size(); i++)
		scanf("%d", &vec[i]);
	for (int i = 1; i <= n - 1; i++)
	{
		for (int j = i + 1; j <= n; j++)
		{
			int l = 0; bool wl = false, hl = false;
			for (int z = 1; z <= n; z++)
			{
				if (vec[z] > 0)
					if (vec[z] == i || vec[z] == j)
					{
						l++;
						if (z == i || z == j) wl = true;
						else hl = true;
					}
					else {

					}
				else
				{
					if (vec[z] != -i && vec[z] != -j)
					{
						l++;
						if (z == i || z == j) wl = true;
						else hl = true;
					}
				}
			}
			if (hl && wl && l == 2)
			{
				printf("%d %d\n", i, j);
				return 0;
			}
		}
	}
	printf("No Solution\n");
	return 0;
}

思路:

https://blog.csdn.net/liuchuo/article/details/82560876

猜你喜欢

转载自blog.csdn.net/isunLt/article/details/87896687