1148 Werewolf - Simple Version

1148 Werewolf - Simple Version(20 point(s))

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

player #1 said: “Player #2 is a werewolf.”;
player #2 said: “Player #3 is a human.”;
player #3 said: “Player #4 is a werewolf.”;
player #4 said: “Player #5 is a human.”; and
player #5 said: “Player #4 is a human.”.
Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liers. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liers. You are supposed to point out the werewolves.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:
If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

题目大意:N名玩家有 2 人扮演狼人角色,有 2 人说慌,有狼人撒谎但并非所有狼人都撒谎。你需要找出扮演狼人角色的玩家编号。若有解,递增输出编号;若解不唯一,输出最小序列解即可;否则输出 “No Solution”

本题采用暴力枚举法

//AC code
/*
 暴力枚举法思路如下:
 1:每次前进入两层循环初始化judge[]=1全为好人,然后假设judge[i]=judge[j]=-1为狼人
 2:第三层遍历 v[k],判断v[k]是否说慌, judge[abs(v[k])]*v[k]<0表说谎,push进lie_id数组,并cnt++计数
 3:判断lie_id数组是否符合游戏规则(cnt==2,一个狼人,一个好人说谎) 
 4: 若lie_id数组符合要求 ,则由for循环书写得知编号一定最小 ,若三层循环未找到解决,输出"No Solution" 
 5: 为与编号1~N相对应,数组下标从1开始  
*/
#include<iostream>
#include<vector> 
#include<algorithm>
using namespace std;

int main(){
    int n;
    cin>>n;
    vector<int> v(n+1);
    int judge[n+1];
    for(int i=1;i<=n;i++) cin>>v[i];
    for(int i=1;i<=n;i++){
        for(int j=i+1;j<=n;j++){
            fill(judge,judge+n+1,1); 
            vector<int> lie_id;
            judge[i]=judge[j]=-1;  
            int cnt=0;             
            for(int k=1;k<=n;k++)
                if(v[k]*judge[abs(v[k])]<0){  
                    lie_id.push_back(k);
                    cnt++;
                }
            if(cnt==2 && judge[lie_id[0]]*judge[lie_id[1]]<0){  
                    cout<<i<<" "<<j<<endl;
                    return 0;
            }
        }
    }
    cout<<"No Solution"<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41317652/article/details/82597546