PTA_甲_1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

输入a,b两个数,将a,b之和进行格式化输出,每三位加一个逗号,不满三位不变

代码:

import java.text.DecimalFormat;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) throws Exception {
        Scanner in = new Scanner(System.in);
        int a = in.nextInt();
        int b = in.nextInt();
        int sum =a+b;
        String str = String.valueOf(sum);
        if(str.length()<4)
            System.out.println(sum);
        else
            System.out.println(new DecimalFormat(",###").format(sum));
    }
}
发布了18 篇原创文章 · 获赞 0 · 访问量 174

猜你喜欢

转载自blog.csdn.net/qq_41576720/article/details/104079724
今日推荐