PAT 甲 1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
题意:
题目大概意思是计算A+B的和,然后以每三位输出一个分隔逗号
思路:
先计算出来a+b,然后如果是负数,先把-号输出,然后把和变为正数,然后再转为字符串,遍历字符串,根据(i+1)%3==len%3&&i!=len-1输出逗号。
C++代码:

#include<cstdio>
#include<iostream>
#include<string> 
using namespace std;
int main(){
	int a,b,sum;
	cin>>a>>b;
	sum=a+b;
	if(sum<0){
		cout<<"-";
		sum=-sum; 
	}
	string s=to_string(sum);
	int len=s.length();
	for(int i=0;i<len;i++){
		cout<<s[i];
		if((i+1)%3==len%3&&i!=len-1){
			cout<<',';
		}
	}
	return 0;
} 
发布了65 篇原创文章 · 获赞 5 · 访问量 4150

猜你喜欢

转载自blog.csdn.net/u014424618/article/details/105009543