PTA1001 A+B Format

1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;

int main()
{
    int a,b;
    int i,num,t;
    char s[20];
    cin>>a>>b;
    a+=b;
    b=a;
    a=abs(a);
    num=0;
    t=0;
    while(a)
    {
        s[num++]=a%10+'0';
        t++;
        a=a/10;
        if(t==3&&a!=0)//注意刚好是三个数的情况
        {
            t=0;
            s[num++]=',';
        }
    }
    if(b<0)
        s[num++]='-';
    if(b==0) cout<<"0";//注意结果为零的情况
    for(i=num-1;i>=0;i--)
    {
        cout<<s[i];
    }
return 0;
} 

猜你喜欢

转载自blog.csdn.net/csdn_muxin/article/details/81033874
今日推荐