A1001 A+B Format

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int num[10];
int main()
{
	int a, b, sum = 0;
	scanf("%d%d", &a, &b);
	sum = a + b;
	if(sum < 0) {
		printf("-");
		sum = -sum;
	}
	int len = 0;
	do {
		num[len++] = sum % 10;
		sum /= 10; 
	}while(sum);
	
	for(int k = len - 1; k >= 0; k--){
		printf("%d", num[k]);
		if(k > 0 && k % 3 == 0) printf(",");
	}
	return 0;
}
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int num[10];
int main()
{
	int a, b, sum = 0;
	scanf("%d%d", &a, &b);
	sum = a + b;
	if(sum < 0) {
		printf("-");
		sum = -sum;
	}
	if(sum >= 1e6) printf("%d,%03d,%03d", sum/1000000, sum%1000000/1000, sum%1000);
	else if(sum >= 1000) printf("%d,%03d", sum/1000, sum%1000);
	else printf("%d", sum); 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Highlight_Jin/article/details/88769131
今日推荐