【PAT】A1118 Birds in Forest (25point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 150 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1118 Birds in Forest (25point(s))

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10^​4​​ ) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​ … B​K
​​
where K is the number of birds in this picture, and B​i​​ 's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​^4​​ .

After the pictures there is a positive number Q (≤10​^4​​ ) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

Code

#include <stdio.h>
#include <iostream>
#include <vector>
using namespace std;
int father[10010],appear[10010],cluCnt[10010];
vector<int> bs;
int findFather(int x){
    if(x==father[x])    return x;
    else{
        int F=findFather(father[x]);
        father[x]=F;
        return F;
    }
}
void Union(int a,int b){
    int faA=findFather(a),faB=findFather(b);
    if(faA!=faB)    father[faA]=faB;
}
int main(){
    int n,k,q,a,b,bird,cnt=0,maxmem=0;
    scanf("%d",&n);
    for(int i=0;i<10010;i++)    father[i]=i;
    for(int i=0;i<n;i++){
        scanf("%d",&k);
        bs.clear();
        for(int j=0;j<k;j++){
            scanf("%d",&bird);
            bs.push_back(bird);
            //if(bird>maxmem) maxmem=bird;
        }
        for(int j=0;j<k;j++){
            Union(bs[j],bs[0]);
            appear[bs[j]]=1;
        }
    }
    for(int i=0;i<10010;i++)    if(appear[findFather(i)]==1)    cluCnt[findFather(i)]++;
    for(int i=0;i<10010;i++){
        if(cluCnt[i]>=1){
            cnt++;
            maxmem+=cluCnt[i];
        }
    }
    scanf("%d",&q);
    printf("%d %d\n",cnt,maxmem);
    for(int i=0;i<q;i++){
        scanf("%d %d",&a,&b);
        if(findFather(a)==findFather(b))    printf("Yes\n");
        else    printf("No\n");
    }
    return 0;
}

Analysis

-使用并查集模板。在输入时,将同一张图中的鸟合并。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/104056946
今日推荐