1118 Birds in Forest (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/acm_zh/article/details/87914854

1118 Birds in Forest (25 分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No
#include<iostream>
#include<vector>
#include<set>
int inf = 10005;
using namespace std;
vector<int> f(inf);
vector<int> book(10005,0);
int getf(int v){
	if(f[v] == v) return v;
	else{
		f[v] = getf(f[v]);
		return f[v];
	}
}
void merge(int x,int y){
	int t1 = getf(x);
	int t2 = getf(y);
	if(t1 != t2){
		f[t2] = t1;
	}
}
int main(){
	int n;
	cin >> n;
	set<int> s;
	for(int i = 0;i < inf;i++){
		f[i] = i;
	}
	while(n--){
		int k;
		cin >> k;
		vector<int> v(k);
		for(int i = 0;i < k;i++){
			cin >> v[i];
			book[v[i]] = 1;
			s.insert(v[i]);
		}
		for(int i = 1;i < k;i++){
			merge(v[0],v[i]);
		}
	}
	int k,cnt=0;
	cin >> k;
	for(int i = 0;i < inf;i++){
		f[i] = getf(f[i]);
		if(f[i] == i && book[f[i]]){
			cnt++;
		}
	}
	cout << cnt << " " << s.size() << endl;
	for(int i = 0;i < k;i++){
		int a,b;
		cin >> a >> b;
		int t1 = getf(a);
		int t2 = getf(b);
		if(t1 != t2){
			cout << "No" << endl;
		}else{
			cout << "Yes" << endl;
		}
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/acm_zh/article/details/87914854