HDU 5310 Souvenir

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5310

Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, wants to buy a souvenir for each contestant. You can buy the souvenir one by one or set by set in the shop. The price for a souvenir is p yuan and the price for a set of souvenirs if q yuan. There's m souvenirs in one set.

There's n contestants in the contest today. Soda wants to know the minimum cost needed to buy a souvenir for each contestant.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105), indicating the number of test cases. For each test case:

There's a line containing 4 integers n,m,p,q (1n,m,p,q104).
 

Output
For each test case, output the minimum cost needed.
 

Sample Input
 
  
2 1 2 2 1 1 2 3 4
 

Sample Output
 
  
1 3
Hint
For the first case, Soda can use 1 yuan to buy a set of 2 souvenirs. For the second case, Soda can use 3 yuan to buy a souvenir.

#include<iostream>
using namespace std;
int main()
{
//	freopen("E:\\in.txt","r",stdin);
	int T;
	cin>>T;
	while(T--){
		bool flag=false;
		int n,m,p,q;
		int cost=0;
		cin>>n>>m>>p>>q;
		if(m*p>q)flag=true;	//set is cheaper
		while(n>=m){
			if(flag){
				n-=m;
				cost+=q;
			}
			else{
				n-=1;
				cost+=p;
			}
		}
		if(n){	//rest need to buy
			if(n*p>q)
				cost+=q;
			else
				cost+=p*n;
		}
		cout<<cost<<endl;
	}
	return 0;
}
				


发布了54 篇原创文章 · 获赞 62 · 访问量 10万+

猜你喜欢

转载自blog.csdn.net/u013053268/article/details/48340553
hdu
今日推荐