hdu_1505 City Game(单调栈)

City Game
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8943 Accepted Submission(s): 3884

Problem Description
Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you’re building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input
The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

Output
For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input
2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output
45
0

Source
Southeastern Europe 2004

Recommend
zl | We have carefully selected several similar problems for you: 1203 1176 1231 1087 2870

题意:找到所给的数据中的由F组成的最大的矩形。
思路:运用单调栈的思想把整个矩形的每一行当作单独的一个单调栈来处理,注意该题的输入。

下面就是代码啦

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <stack>
using namespace std;
const int maxn = 2010;
const int inf = 0x3f3f3f3f;
typedef long long ll;
char map[maxn][maxn];
int s[maxn][maxn];
int a[maxn],b[maxn];
int n,m;
struct node
{
    int x,y;
};
void unit()
{
    char st[12];
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            scanf("%s",st);
            map[i][j]=st[0];
        }
}
int main()
{
    int t;
    cin>>t;
    while(t--){
        scanf("%d %d",&n,&m);
        unit();
        for(int i=1;i<=m;i++){
            s[0][i]=0;
            for(int j=1;j<=n;j++){
                s[j][i]=s[j-1][i];
                if(map[j][i]=='F'){
                    s[j][i]++;
                }
                else{
                    s[j][i]=0;
                }
            }
        }
        int ans=0;
        for(int i=1;i<=n;i++){
            stack<node>q;
            q.push({0,0});
            for(int j=1;j<=m;j++){
                node c=q.top();
                if(c.x<s[i][j]){
                    q.push({s[i][j],j});
                }
                else if(c.x>s[i][j]){
                    int y=0;
                    while(1){
                        c=q.top();
                        if(c.x<=s[i][j])break;
                        q.pop();
                        ans=max(ans,c.x*(j-c.y));
                        y=c.y;
                    }
                    q.push({s[i][j],y});
                }
            }
            while(!q.empty()){
                node c=q.top();
                q.pop();
                ans=max(ans,c.x*(m+1-c.y));
            }
        }
        cout<<ans*3<<endl;
    }
    return 0;
}
发布了35 篇原创文章 · 获赞 25 · 访问量 829

猜你喜欢

转载自blog.csdn.net/qq_43816599/article/details/100125360
今日推荐