1023 Have Fun with Numbers (20 分)(简单模拟大数加)

1023 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
char a[30],b[30];
int numa[15],numb[15]; 
int main(){
    scanf("%s",a+1);
    int len=strlen(a+1);
    int tmp=0;
    int tot=0;
    for(int i=len;i>0;i--){
    	int cnt=(a[i]-'0')*2+tmp;
    	b[++tot]=cnt%10+'0';
    	tmp=cnt/10;
    }
    if(tmp>0) b[++tot]=tmp+'0';
    for(int i=1;i<=len;i++) numa[a[i]-'0']++;
    for(int i=tot;i>0;i--) numb[b[i]-'0']++;
    bool flag=true;
    for(int i=0;i<=9;i++){
    	if(numa[i]!=numb[i]){
    	   flag=false;
    	   break;
	}
    }
    if(flag) printf("Yes\n");
    else printf("No\n");
    for(int i=tot;i>0;i--) printf("%c",b[i]);
    return 0;
}





发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/102811780