【笨方法学PAT】1023 Have Fun with Numbers (20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/82825757

一、题目

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

二、题目大意

给一个长度不超过20位的整数,问这个整数的两倍后的数位是不是原整数数位的一个排列。

三、考点

大数乘法

四、解题思路

1、使用string保存数字;

2、使用一维数组保存每位上的数字;

3、大数乘法;

4、新数字每一位对一维数组求减;

5、判断最终一维数组meiy每一位是否恰好消除。

五、代码

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main() {
	//read
	string s, t="";
	cin >> s ;

	//solve the original number
	int a[10] = {0};
	for (int i = 0; i < s.length(); ++i) 
		a[s[i] - '0'] ++ ;

	//double the number
	reverse(s.begin(), s.end());
	int jin = 0;
	for (int i = 0; i < s.length(); ++i) {
		int b = jin + 2*(s[i] - '0');
		t += (char)(b % 10 + '0');
		jin = b / 10;
	}
	if (jin != 0)
		t += (char)(jin + '0');
	reverse(t.begin(), t.end());

	//solve the second number
	for (int i = 0; i < t.length(); ++i) 
		a[t[i] - '0']--;
	
	//result
	bool flag = true;
	for (int i = 0; i < 10; ++i) {
		if (a[i] != 0) {
			flag = false;
			break;
		}
	}
	if (flag == true)
		cout << "Yes" << endl;
	else
		cout << "No" << endl;
	cout << t << endl;

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/82825757
今日推荐