1023 Have Fun with Numbers (20)(20 分)

版权声明:实不相瞒,我也想成为大佬 https://blog.csdn.net/CV_Jason/article/details/81415442


1 题目

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:
Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.
Sample Input:

1234567899

Sample Output:

Yes
2469135798

题目链接:

2 解题思路

  给定一个数,乘以2之后,各个数位的出现次数,是否与乘之前是否相同,相同输出Yes,否认输出No,然后下一行打印出乘2之后的各个数位。
  这个题目是属于超大数运算的类型,题目给出的最高数位是20位,那么即便是用最高的unsigned long long 也会面临溢出的情况,所以输入和输出,只能用string,诸位乘2,然后再记录每一位出现的次数,相比较就行。

3 AC代码

/*
** @Brief:No.1023 of PAT advanced level.
** @Author:Jason.Lee
** @Date:2018-8-04
*/

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;

int digit[10];
string input;
string output;

bool doubleNumber(string input){
    int flag = 0;
    int temp = 0;
    output.resize(input.length());
    for(int i = input.length()-1;i>=0;i--){
        temp = (int)(input[i]-'0');

        digit[temp]++;
        temp=2*temp+flag;

        if(temp>9){
            temp%=10;
            flag = 1;
        }else{
            flag = 0;
        }
        output[i] = (temp+'0');
        //cout<<"ouput :"<<output[i]<<endl;
    }
    if(flag){
        output= "1"+output;
    }
    //cout<<"output : "<<output<<endl;
    //cout<<"size : "<<output.length()<<endl;
    for(int i = 0;i<output.length();i++){
        digit[(int)(output[i]-'0')]--;
    }
    for(int i=0;i<10;i++){
        if(digit[i]!=0){
            return false;
        }
    }
    return true;
}
int main(){
    cin>>input;
    cout<<(doubleNumber(input)? "Yes":"No")<<endl;
    cout<<output<<endl;
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/CV_Jason/article/details/81415442