1031 Hello World for U (20 分)(打印题)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor
#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
char s[100];
char mp[100][100];
int main(){
    scanf("%s",s+1);
    int len=strlen(s+1);
    int n1=(len+2)/3;
    int n3=n1;
    int n2=len+2-n1-n3;
    for(int i=1;i<=n1;i++){
    	for(int j=1;j<=n2;j++){
    	    mp[i][j]=' ';
	}
    }
    int cnt=0;
    for(int i=1;i<=n1;i++) mp[i][1]=s[++cnt];
    for(int i=2;i<n2;i++) mp[n1][i]=s[++cnt];
    for(int i=n3;i>=1;i--) mp[i][n2]=s[++cnt];
    for(int i=1;i<=n1;i++){
    	for(int j=1;j<=n2;j++){
    	    printf("%c",mp[i][j]);
	}
	printf("\n");
    }
    return 0;
}





发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/103267847
今日推荐