1031 Hello World for U (20 分)(打印图形)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d

e  l

l  r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n

1

characters, then left to right along the bottom line with n

2

characters, and finally bottom-up along the vertical line with n

3

characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n

1

=n

3

=max { k | kn

2

for all 3≤n

2

N } with n

1

+n

2

+n

3

−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !

e   d

l   l

lowor

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
using namespace std;
int main(){
    char a[80];
    scanf("%s",a);
    int len=strlen(a);
    int n=len+2;
    int n1=n/3,n2=n/3+n%3;
    for(int i=0;i<n1-1;i++){
        printf("%c",a[i]);
        for(int j=0;j<n2-2;j++)
            printf(" ");
        printf("%c\n",a[len-i-1]);
    }
    for(int i=0;i<n2;i++)
        printf("%c",a[n1-1+i]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42068614/article/details/86615365