【笨方法学PAT】1031 Hello World for U (20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/83270233

一、题目

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

二、题目大意

题目要求将給定字符串按照“U”字形输出。其中n1为左侧字符数,n2为底部字符数,n3为右侧字符数,且均包含拐角处相交字符,且有如下要求:

  • n1 == n3
  • n2 >= n1
  • n1 尽可能大

三、考点

string

四、解题思路

1、最麻烦的是求解n1、n2,求解之后输出即可

五、代码

#include<iostream>
#include<string>
using namespace std;
int main() {
	//read
	string s;
	cin >> s;

	//get n1,n2
	int n1, n2;
	n1 = (s.length() + 2) / 3;
	n2 = s.length() + 2 - 2 * n1;

	//output
	for (int i = 0; i < n1-1; ++i) {
		cout << s[i];
		for (int j = 0; j < n2 - 2; ++j)
			cout << " ";
		cout << s[s.length() - i - 1]<<endl;
	}
	for (int i = n1-1; i < n1 + n2-1; ++i)
		cout << s[i];

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/83270233
今日推荐