HDU 1326 Box of Bricks(思维)

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help? 

InputThe input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100. 

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. 

The input is terminated by a set starting with n = 0. This set should not be processed. 
OutputFor each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

Output a blank line after each set. 
Sample Input

6
5 2 4 1 7 5
0

Sample Output

Set #1
The minimum number of moves is 5.

题意:使高度相同的最少移动次数
代码:
import java.util.Scanner;
public class Main {
      public static void main(String[] args) {
           Scanner scan=new Scanner(System.in);
           int k=1;
           while(scan.hasNext()){
                 int n=scan.nextInt();
                 if(n==0) break;
                 int a[]=new int[n];
                 int sum=0;
                 for(int i=0;i<n;i++) {
                      a[i]=scan.nextInt();
                      sum+=a[i];
                 }
                 int avg=sum/n,min=0;
                 for(int i=0;i<n;i++){
                     if(a[i]<avg) min+=(avg-a[i]);
                 }
                 System.out.println("Set #"+(k++));
                 System.out.println("The minimum number of moves is "+min+".");
                 System.out.println();
           }
    }
}

猜你喜欢

转载自www.cnblogs.com/qdu-lkc/p/12192648.html
Box