Box

Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up wooden
boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular
parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side
of the box.
Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivan
pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of
time to explain Joe that he has made a mistake.
Fortunately, Joe adores everything related to computers and sincerely believes that computers never
make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program
that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.
Input
Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet
and contains two integer numbers w and h (1 ≤ w, h ≤ 10 000) — width and height of the pallet in
millimeters respectively.
Output
For each test case, print one output line. Write a single word ‘POSSIBLE’ to the output file if it is
possible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is not
possible to do so.
Sample Input
1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683
1234 4567
1234 4567
4567 4321
4322 4567
4321 1234
4321 1234
Sample Output
POSSIBLE
IMPOSSIBLE
代码
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<ctype.h>
struct square
{
int w;
int h;
}squ[17],squa[7];
int a[17];
int main()
{
int i,j,k,k1;
while(scanf("%d%d%d%d%d%d%d%d%d%d%d%d",&squ[1].w,&squ[1].h,&squ[2].w,&squ[2].h,&squ[3].w,&squ[3].h,&squ[4].w,&squ[4].h,&squ[5].w,&squ[5].h,&squ[6].w,&squ[6].h)!=EOF)
{
k=1;
for(i=1;i<=5;i++)
{
if(a[i]!=0)
continue;
for(j=i+1;j<=6;j++)
{
if(a[j]!=0)
continue;
if((squ[i].wsqu[j].w&&squ[i].hsqu[j].h)||(squ[i].wsqu[j].h&&squ[i].hsqu[j].w))
{
a[i]=k;
a[j]=k;
k++;
break;
}
}
}
if(k!=4)
printf(“IMPOSSIBLE\n”);
else
{
k=0;
k1=1;
for(i=1;i<=5;i++)
{
if(a[i]k1)
{
squa[k1].w=squ[i].w;
squa[k1].h=squ[i].h;
k1++;
}
}
if(squa[3].w
squa[1].w)
{
if(squa[2].wsqua[3].h&&squa[2].hsqua[1].h)
k=1;
if(squa[2].wsqua[1].h&&squa[2].hsqua[3].h)
k=1;
}
if(squa[3].wsqua[1].h)
{
if(squa[2].w
squa[3].h&&squa[2].hsqua[1].w)
k=1;
if(squa[2].w
squa[1].w&&squa[2].hsqua[3].h)
k=1;
}
if(squa[3].w
squa[2].w)
{
if(squa[1].wsqua[3].h&&squa[1].hsqua[2].h)
k=1;
if(squa[1].wsqua[2].h&&squa[1].hsqua[3].h)
k=1;
}
if(squa[3].wsqua[2].h)
{
if(squa[1].w
squa[3].h&&squa[1].hsqua[2].w)
k=1;
if(squa[1].w
squa[2].w&&squa[1].hsqua[3].h)
k=1;
}
if(k
1)
printf(“POSSIBLE\n”);
else
printf(“IMPOSSIBLE\n”);
}
memset(a,0,sizeof(a));
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/86256248
Box