Round Numbers POJ - 3252(数位dp)

题目

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively Start and Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start… Finish
Sample Input
2 12
Sample Output
6

解释

注意前导零对结果的影响比如12 (1100)到1的枚举中会出现(0110),如果不考虑就单纯记录0的个数,错误严重。
int 大于2*10e9一些些,int足够。

#include <cstdio>
#include <cstring>
int const maxn = 50;
using namespace std;
int dp[maxn][maxn][maxn]; 
int dig[maxn];
int dfs(int pos, int num1, int num2, int flag, int limit){
	if(pos == -1) return num1 >= num2 ? 1 : 0; 
	if(!limit && dp[pos][num1][num2] != -1) return dp[pos][num1][num2];
	int up = limit ? dig[pos] : 1; 
	int ans = 0;
	for(int i = 0; i <= up; i++){
		if(flag && i == 0)
			ans += dfs(pos-1, num1, num2, flag, limit && i == up); 
		else
			ans += dfs(pos-1, num1+1-i, num2+i, 0,limit && i == up);
	}
	if(!limit) dp[pos][num1][num2] = ans;
	return ans;
} 
int slove(int x){
	int pos = 0;
	while(x){
		dig[pos++] = x%2;
		x /= 2;	
	}
	int ans;
	ans =  dfs(pos-1,0, 0, 1, 1);
	return ans;
} 
int main(){
	int n, m;
	memset(dp, -1, sizeof(dp));
	scanf("%d %d", &n, &m);
	printf("%d\n", slove(m) - slove(n-1));
	
	
	return 0;
} 
发布了52 篇原创文章 · 获赞 2 · 访问量 857

猜你喜欢

转载自blog.csdn.net/qq_44714572/article/details/103570139