[数位DP] E - Round Numbers POJ - 3252

Round Numbers

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15949   Accepted: 6549

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

Source

USACO 2006 November Silver

#include <iostream>
#include <cstdio>

using namespace std;

int ch[100];
int dp[100][100][100];
bool flag;

int dfs(int pos, int zero, int one, int limit)
{
	if (pos == 0)
		return zero >= one;
		
	if (!limit && dp[pos][zero][one])
		return dp[pos][zero][one];
	
	int res = 0;
	int up = limit ? ch[pos] : 1;
	for (int i = 0; i <= up; i++)
	{
		/// flag判断前导0
		if (i == 0)
			res += dfs(pos - 1, zero + flag, one, limit && i == up);
		if (i == 1)
		{
			flag = 1;
			res += dfs(pos - 1, zero, one + 1, limit && i == up);
		}
	}
	if (!limit)  /// 到pos为止高位0和1的个数
		dp[pos][zero][one] = res;
	
	return res;
}

int solve(int n)
{
	flag = 0;
	int cnt = 0;
	while (n > 0)
	{
		ch[++cnt] = n % 2;
		n = n >> 1;
	}
	return dfs(cnt, 0, 0, 1);
}

int main()
{
	int a, b;
	while (~scanf("%d %d", &a, &b))
		printf("%d\n", solve(b) - solve(a - 1));
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/81673163