poj3252 Round Numbers(数位dp)

Round Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16439   Accepted: 6776

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6

Source

题意: 转换成2进制中,0的个数不少于1的个数
题解: 数位DP
直接组合也可以搞出来的
代码:
#include<stdio.h>
#include<string.h>
typedef long long ll;
int n,m;
int dp[40][40][40];//状态就是要记录二进制中0和1的数
int bit[40];
ll dfs(int pos,int num0,int num1,bool lead,bool limit)
{
    if(pos==-1)return num0>=num1;
    if(!limit&&!lead&&dp[pos][num0][num1]!=-1)return dp[pos][num0][num1];
    int up=limit?bit[pos]:1;
    ll ans=0;
    for(int i=0;i<=up;i++)
    {
        ans+=dfs(pos-1,(lead&&i==0)?0:num0+(i==0),(lead&&i==0)?0:num1+(i==1),lead&&i==0,limit&&i==bit[pos]);
    }
    if(!limit&&!lead)dp[pos][num0][num1]=ans;
    return ans;
}
ll solve(ll x)
{
    int len=0;
    while(x)
    {
        bit[len++]=x&1;
        x>>=1;
    }
    return dfs(len-1,0,0,1,1);
}
int main()
{
    memset(dp,-1,sizeof(dp));
    scanf("%d %d",&n,&m);
    printf("%lld\n",solve(m)-solve(n-1));
}

猜你喜欢

转载自www.cnblogs.com/zhgyki/p/9751669.html