prime模板

int d[N],map[N][N];
bool vis[N];
int  prime()
{
	memset(d,0x3f,sizeof(d));
	memset(vis,false,sizeof(vis));
	int ans=0;
	for(int i=0;i<P;i++)
	{
		int v=-1;//选一个点加入集合
		for(int j=1;j<=P;j++)
		{
			if(!vis[j]&&(v==-1||d[v]>d[j])) 
			{
				v=j;//找到最短距离点 
			 } 
		}
		vis[v]=1;
		if(i)//代表不是第一个点 
			ans+=d[v];
			for(int j=1;j<=P;j++)
			{
				d[j]=min(d[j],map[v][j]);//更新最短距离 
			}
	 } 
	 return ans;
}

或者

int prime()
{
	memset(low,0x3f,sizeof(low));
	memset(vis,false,sizeof(vis));
	int min,v,ans=0,m;
	for(int i=1;i<=n;i++)
	{
		low[i]=map[1][i];
//		vis[i]=0;
	}
	vis[1]=1;
	for(int i=1;i<n;i++)
	{
		m=0x3f3f3f3f;
		for(int j=1;j<=n;j++)
		{
			if(!vis[j]&&low[j]<m)
			{
				m=low[j];
				v=j;
			}
		}
		vis[v]=1;
		ans+=low[v];
		for(int j=1;j<=n;j++)
		{
			if(!vis[j]&&low[j]>map[v][j])
			{
				low[j]=map[v][j];
			}
		}
	}
	return ans;
}

例子:
You are assigned toint prime()
{
memset(low,0x3f,sizeof(low));
memset(vis,false,sizeof(vis));
int min,v,ans=0,m;
for(int i=1;i<=n;i++)
{
low[i]=map[1][i];
// vis[i]=0;
}
vis[1]=1;
for(int i=1;i<n;i++)
{
m=0x3f3f3f3f;
for(int j=1;j<=n;j++)
{
if(!vis[j]&&low[j]<m)
{
m=low[j];
v=j;
}
}
vis[v]=1;
ans+=low[v];
for(int j=1;j<=n;j++)
{
if(!vis[j]&&low[j]>map[v][j])
{
low[j]=map[v][j];
}
}
}
return ans;
} design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input
The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.
Output
For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
Sample Input
1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0
Sample Output
0
17
16
26

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int P,R,map[60][60],d[60];
bool vis[60];
int  prime()
{
	memset(d,0x3f,sizeof(d));
	memset(vis,false,sizeof(vis));
	int ans=0;
	for(int i=0;i<P;i++)
	{
		int v=-1;//选一个点加入集合
		for(int j=1;j<=P;j++)
		{
			if(!vis[j]&&(v==-1||d[v]>d[j])) 
			{
				v=j;//找到最短距离点 
			 } 
		}
		vis[v]=1;
		if(i)//代表不是第一个点 
			ans+=d[v];
			for(int j=1;j<=P;j++)
			{
				d[j]=min(d[j],map[v][j]);//更新最短距离 
			}
	 } 
	 return ans;
}
int main()
{
	while(scanf("%d",&P),P)
	{
		scanf("%d",&R); 
		int a,b,c;
		memset(map,0x3f,sizeof(map));
		for(int i=1;i<=R;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			map[a][b]=map[b][a]=min(map[a][b],c);
		}
		//printf("%d\n",prime());	
		cout<<prime()<<endl;
	}
	return 0;
 } 
发布了22 篇原创文章 · 获赞 6 · 访问量 1707

猜你喜欢

转载自blog.csdn.net/qq_44759750/article/details/103939447