1029 Median (25 point(s)) - C语言 PAT 甲级

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/huaxuewan/article/details/100905329

1029 Median (25 point(s))

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤ 2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题目大意:

输入两个升序序列,第一个数 N 表示序列有 N 个数,输出合并两个序列后的中间数

设计思路:
  1. 两个序列都存下来,会超过题目要求的内存限制

  2. 储存第一个序列,第二个序列不储存,在输入的过程中寻找中间数;序列分别有 n1 和 n2 个数,则中间数在 (n + m + 1) / 2 的位置

  3. 序列后面加一个最大值 INT_MAX 当“哨兵”,可以简化处理过程

编译器:C (gcc)
#include <stdio.h>
#include <limits.h>

int main(void)
{
	int n1, num1[200001], n2, num2, median;
	int i;
	scanf("%d", &n1);
	for (i = 0; i < n1; i++)
		scanf("%d", &num1[i]);
	num1[n1] = INT_MAX;

	int *p = num1, n;
	scanf("%d", &n2);
	n = (n1 + n2 + 1) / 2;
	if (n2 > 0) {
		scanf("%d", &num2);
		n2--;
	} else {
		num2 = INT_MAX;
	}

	for (i = 0; i < n; i++) {
		if (*p < num2 && p < num1 + n1) {
			median = *p;
			p++;
		} else {
			median = num2;
			if (n2 > 0)
				scanf("%d", &num2);
			else
				num2 = INT_MAX;
			n2--;
		}
	}

	if (n)
		printf("%d", median);

	return 0;
}

猜你喜欢

转载自blog.csdn.net/huaxuewan/article/details/100905329