1028 List Sorting (25 point(s)) - C语言 PAT 甲级

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/huaxuewan/article/details/100904538

1028 List Sorting (25 point(s))

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤ 105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题目大意:

输入 N 个学生信息,id、name、grade;

根据 C 的值排序,当 C 为 1,按第一列升序;当 C 为 2,按第二列不降序;当 C 为 3,按第三列不降序;第二、三列值相同时,按 id 升序;

设计思路:

按题目要求排序后,输出

编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct stu {
	int id;
	char name[9];
	int grade;
};

int cmp1(const void *a, const void *b)
{
	struct stu *s1 = (struct stu*)a, *s2 = (struct stu*)b;
	return s1->id - s2->id;
}

int cmp2(const void *a, const void *b)
{
	struct stu *s1 = (struct stu*)a, *s2 = (struct stu*)b;
	int flag;
	flag = strcmp(s1->name, s2->name);
	if (flag)
		return flag;
	else
		return s1->id - s2->id;
}

int cmp3(const void *a, const void *b)
{
	struct stu *s1 = (struct stu*)a, *s2 = (struct stu*)b;
	int flag;
	flag = s1->grade - s2->grade;
	if (flag)
		return flag;
	else
		return s1->id - s2->id;
}

int main(v9id)
{
	int n, c;
	struct stu stus[100000] = {0};
	int i;

	scanf("%d %d", &n, &c);
	for (i = 0; i < n; i++)
		scanf("%d %s %d", &stus[i].id, stus[i].name, &stus[i].grade);

	if (c == 1)
		qsort(stus, n, sizeof(struct stu), cmp1);
	else if (c == 2)
		qsort(stus, n, sizeof(struct stu), cmp2);
	else
		qsort(stus, n, sizeof(struct stu), cmp3);

	for (i = 0; i < n; i++)
		printf("%06d %s %d\n", stus[i].id, stus[i].name, stus[i].grade);


	return 0;
}

猜你喜欢

转载自blog.csdn.net/huaxuewan/article/details/100904538