Visible Lattice Points (GCD)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_23320955/article/details/79347554

Visible Lattice Points

解题思路

(x,y)与原点连线所在直线斜率不相等,则两条直线不共线(可以利用GCD算法),而且存在关于y=x存在对称关系,则可以将具有对称关系的点标记

题目描述

题目链接

A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.

Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, y ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

AC代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;
const int maxn = 1005;
int num[maxn][maxn];
int gcd(int m, int n)
{
    if(m < n) gcd(n, m);
    int r;
    do{
        r = m % n;
        m = n;
        n = r;
    }while(r);
    return m;
}
int main()
{
    memset(num, 0, sizeof(num));
    for(int i = 1; i < maxn; i++) {
        for(int j = 1; j < maxn; j++) {
            int r = 0;
            if(!num[i][j] && (r = gcd(i, j)) == 1) num[i][j] = num[j][i] = 1;
        }
    }
    int c;
    scanf("%d", &c);
    int flag = 1;
    while(c --)
    {
        int n;
        scanf("%d", &n);
        int cnt = 3;
        for(int i = 1; i <= n; i ++)
        {
            for(int j = 1; j < i; j ++)
            {
                if(num[i][j] == 1)
                    {
                        cnt += 2;
                    }
            }
        }
        printf("%d %d %d\n", flag ++, n, cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_23320955/article/details/79347554