【题解】poj3090 Visible Lattice Points 欧拉函数

题目链接

Description

A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.

这里写图片描述
Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, y ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549


显然易得,除(1,0)(0,1)(1,1)三个钉子外,一个钉子能被看见当且仅当1<=x,y<=N且gcd(x,y)=1,对于每个y,这样的x数量恰好是φ(y),本题答案就是3+2*∑φ(i)
可以利用线性筛的思想,在O(N)的时间内求出φ值

#include<cstdio>
const int N=1e3+10;
int phi[N],prime[N],p,n,c,v[N],sum[N],ca;
void euler()
{
    for(int i=2;i<=1000;i++)
    {
        if(!v[i])
        {
            v[i]=i;prime[p++]=i;
            phi[i]=i-1;
        }
        for(int j=0;j<p&&i*prime[j]<=1000;j++)
        {
            v[prime[j]*i]=prime[j];
            phi[i*prime[j]]=phi[i]*(i%prime[j]?prime[j]-1:prime[j]);
        } 
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    scanf("%d",&c);
    euler();
    for(int i=2;i<=1000;i++)sum[i]=sum[i-1]+phi[i];
    while(c--)
    {
        scanf("%d",&n);
        printf("%d %d %d\n",++ca,n,3+2*sum[n]);
    }
    return 0;
}

总结

把问题转化为欧拉函数求解

猜你喜欢

转载自blog.csdn.net/qq_41958841/article/details/82498985