POJ 3090 Visible Lattice Points【欧拉函数】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。<br> https://blog.csdn.net/sodacoco/article/details/89004663

题目:

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

                                       

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

题目大意: 

       从原点(0,0)向第一象限看,能看到多少不同的点。

解题思路:

       1》以前做过的一道题,一看这不就是求x,y互质的数目吗,用欧拉函数写了一遍,不对;同学说这是莫比乌斯函数,去看莫比乌斯函数,,,看不懂,,。

       2》然后开始查图上的点:

       n=1   ans1=2+1;

       n=2   ans2=ans1+2;

       n=3   ans3=ans2+4;

       n=4   ans4=ans3+4;

       3》然后又反应过来这图是对称的;

       就得到:

       n=1   ans1=2+1;

       n=2   ans2=ans1+1*2;

       n=3   ans3=ans2+2*2;

       n=4   ans4=ans3+2*2;

       4》万幸我刚打了一遍欧拉函数的表,立马反应过来:

       n=1   ans1=2+1;

       n=2   ans2=ans1+phi[2]*2;

       n=3   ans3=ans2+phi[3]*2;

       n=4   ans4=ans3+phi[4]*2;

       5》欧拉函数的变形,舒服。

实现代码:

#include <iostream>
#include <stdio.h>
using namespace std;

int phi[1010],sum[1010];
void phi_table(int n)    //欧拉函数打表
{
    for(int i=2;i<=n;i++) phi[i]=0;
    phi[1]=1;
    for(int i=2;i<=n;i++) if(!phi[i])
    for(int j=i;j<=n;j+=i){
        if(!phi[j]) phi[j]=j;
        phi[j]=phi[j]/i*(i-1);
    }
}

int main()
{
    int T,t=1;
    phi_table(1002);
    sum[0]=sum[1]=0;
    for(int i=2;i<=1002;i++)
        sum[i]=sum[i-1]+phi[i];
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        cout<<t++<<" "<<n<<" "<<3+sum[n]*2<<endl;
    }
}  

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/89004663