【set的upperbound】ZOJ 4090 浙大月赛Thanks, TuSimple!

Thanks, TuSimple!


Time Limit: 1 Second      Memory Limit: 65536 KB


In the very first sentence of the very first problem, we would like to give our sincere thanks to TuSimple, the sponsor of this contest.

Founded in 2015, TuSimple is a global autonomous trucking solution company headquartered in San Diego, operating self-driving trucks out of Tucson, Arizona. TuSimple is now developing a commercial-ready Level 4 (SAE) fully-autonomous driving solution for the logistics industry. TuSimple's trucks are the first and only capable of self-driving from depot-to-depot and do so every day for its customers. The company is driven by a mission to increase safety, decrease transportation costs, and reduce carbon emissions.

Nowadays, the trucking industry is currently facing a shortage of 50000 drivers (which is expected to increase to 175000 by the end of 2024) and is approaching a 100 percent turnover rate per year with an average driver age of 49 years old. According to a PwC study, autonomous trucking technologies will reduce annual operating costs for a traditional average long-haul truck by 28 percent in 2025. TuSimple is aiming to transform the 740-billion U.S. trucking industry by cutting costs, reducing carbon emissions and eradicating some of the challenges currently faced by operators.

Building the industry's first 1000-meter perception system, TuSimple soon becomes the pioneer in the industry. As is known to us, 1000 meters can provide 35 seconds of reaction time on average at highway speeds, enabling the system to make the safest and most efficient driving decisions. Even in the adverse weather conditions, the perception system is still designed to identify objects and obstacles, ensuring the safety of both cargoes, trucks, and passers-by. On the other hand, TuSimple's latest proprietary AI is now capable of long-distance highway driving and complex surface street driving, which allows fully autonomous deliveries from one depot to another.

Despite their advanced technology and an enormous sense of mission in the industry, TuSimple shares the corporate culture of honesty, realistic, exploration and innovation among their employees from bottom to top, which allows them to attract more and more elites from all expertise to join and get involved. "Here's why a little-known autonomous trucking company is beating Tesla and Waymo in the race for driverless big rigs", commented by Business Insider.


The future of trucking is now!

As a manager of TuSimple, you are going to hold a dancing party for both the Development Department and the Marketing Department. There will be  gentlemen and ladies in total and they are going to dance in pairs. After a careful investigation, we have already known that for each person, they like to dance with either a taller person or a person with smaller height. To simplify the problem, there are no two persons of the same height and people are only allowed to dance with a person of the opposite gender. In order to reserve a proper dancing field, you must calculate the maximum possible number of pairs of people dancing at the same time.

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers  (), indicating the number of gentlemen and ladies.

The second line contains  integers  (,  for all ), indicating the height of each gentleman.

The third line contains  integers  (,  for all ), indicating the height of each lady.

The fourth line contains  integers  (), indicating the preference of each gentleman. If , it means gentleman  prefers to dance with a lady of smaller height. Otherwise it indicates he prefers to have a taller dancing partner.

The fifth line contains  integers  (), indicating the preference of each lady. If , it means lady  prefers to dance with a gentleman of smaller height. Otherwise it indicates she prefers to have a taller dancing partner.

It's guaranteed that the sum of  and  of all test cases will not exceed  and  for all .

Output

For each test case output one line containing one integer, indicating the answer.

Sample Input

1
3 3
1 2 5
3 4 6
1 1 0
0 0 1

Sample Output

2

Hint

In the sample test case, the 1st gentleman can dance with the 2nd lady, and the 2nd gentleman can dance with the 1st lady.

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
int b[maxn];
struct node
{
    int num,flag;
}a[maxn];
set <int> s[2];
bool cmp(const node &X,const node &Y)
{
    return X.num<Y.num;
}


int vis[maxn];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        s[0].clear();
        s[1].clear();
        memset(vis,0,sizeof vis);
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i].num);
        for(int i=1;i<=m;i++)
            scanf("%d",&b[i]);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i].flag);
        }

        for(int i=1;i<=m;i++)
        {
            int x;
            scanf("%d",&x);
            if(x==0)
                s[0].insert(b[i]);
            else
                s[1].insert(-b[i]);
        }
        sort(a+1,a+n+1,cmp);

        int num=0;
        for(int i=1;i<=n;i++)
        {
            if(a[i].flag==1)
            {
                set<int>::iterator it;
                it=s[0].upper_bound(a[i].num);
                if(it!=s[0].end())
                {
                    if(a[i].num<(*it))
                    {
                        num++;
                        s[0].erase(it);
                    }
                }
            }
            else
            {
                set<int>::iterator it;
                it=s[1].upper_bound(-a[i].num);
                if(it!=s[1].end())
                {
                    if(a[i].num>(*it))
                    {
                        num++;
                        s[1].erase(it);
                    }
                }
            }
        }
        cout<<num<<endl;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/89319734