[POJ2159]Ancient Cipher

Ancient Cipher
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32586   Accepted: 10601

Description

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher. 
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT". 
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO". 
It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP". 
Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

Input

Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet. 
The lengths of both lines of the input are equal and do not exceed 100.

Output

Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.

Sample Input

JWPUDJSTVP
VICTORIOUS

Sample Output

YES

Source


题目地址:http://poj.org/problem?id=2159

题解:判断密码和明文是不是匹配的 题目的描述很绕人 但是其实很水的题目 把所有字母出现的次数用数组记录下来 然后把数组排序 一次对比一下 只要没有不同的那就是相应的明文和密码了 

一开始用map写不知道为什么一直WA WA的代码先贴出来以后慢慢改

WA代码:

#include <iostream>
#include <cstring>
#include <map>
using namespace std;
const int maxn = 110;
map<char, int> pw, pt;
char ch[maxn];
bool mark;

int main() {
    int lenpw, lenpt;

    cin >> ch;
    lenpw = strlen(ch);
    for (int i = 0; i < lenpw; ++i) {
        ++ pw[ch[i]];
    }

    cin >> ch;
    lenpt = strlen(ch);
    for (int i = 0; i < lenpt; ++i) {
        ++ pt[ch[i]];
    }

    if (lenpw != lenpt) {
        mark = false;
    }
    else {
        mark = true;
        map<char, int>::iterator itpw, itpt;
        for (itpw = pw.begin(), itpt = pt.begin(); itpw != pw.end(); ++itpw, ++itpt) {
            if (itpw->second != itpt->second) {
                mark = false;
                break;
            }
        }
    }

    if (mark) {
        cout << "YES" << endl;
    }
    else {
        cout << "NO" << endl;
    }
    return 0;
}


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 110;
char ch[maxn];
int len;
int pw[maxn], pt[maxn];         //pw是密码 pt是明文
bool mark;

int main() {
    scanf("%s", ch);
    len = strlen(ch);
    for (int i = 0; i < len; ++i) {
        ++ pw[ch[i] - 'A'];         //记录每个字母出现的次数 下同
    }
    scanf("%s", ch);
    len = strlen(ch);
    for (int i = 0; i < len; ++i) {
        ++ pt[ch[i] - 'A'];
    }

    sort(pw, pw+26);            //排序
    sort(pt, pt+26);
    mark = true;
    for (int i = 0; i < 26; ++i) {
        if (pw[i] != pt[i]) {       //如果出现不相等 则不管是什么规则转化 都一定不是相匹配的密码和明文
            mark = false;
            break;
        }
    }

    if (mark) {                 //输出结果
        puts("YES");
    }
    else {
        puts("NO");
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/u012431590/article/details/51400374
今日推荐