Ancient Cipher

Ancient Roman empire had a strong government system with various departments, including a secret
service department. Important documents were sent between provinces and the capital in encrypted
form to prevent eavesdropping. The most popular ciphers in those times were so called substitution
cipher and permutation cipher.
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all
letters must be different. For some letters substitute letter may coincide with the original letter. For
example, applying substitution cipher that changes all letters from ‘A’ to ‘Y’ to the next ones in the
alphabet, and changes ‘Z’ to ‘A’, to the message “VICTORIOUS” one gets the message “WJDUPSJPVT”.
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation ⟨2, 1, 5, 4, 3, 7, 6, 10, 9, 8⟩ to the message “VICTORIOUS” one gets the message
“IVOTCIRSUO”.
It was quickly noticed that being applied separately, both substitution cipher and permutation
cipher were rather weak. But when being combined, they were strong enough for those times. Thus,
the most important messages were first encrypted using substitution cipher, and then the result was
encrypted using permutation cipher. Encrypting the message “VICTORIOUS” with the combination of
the ciphers described above one gets the message “JWPUDJSTVP”.
Archeologists have recently found the message engraved on a stone plate. At the first glance it
seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that
was encrypted, and now they want to check their conjecture. They need a computer program to do it,
so you have to write one.
Input
Input file contains several test cases. Each of them consists of two lines. The first line contains the
message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so
the encrypted message contains only capital letters of the English alphabet. The second line contains
the original message that is conjectured to be encrypted in the message on the first line. It also contains
only capital letters of the English alphabet.
The lengths of both lines of the input file are equal and do not exceed 100.
Output
For each test case, print one output line. Output ‘YES’ if the message on the first line of the input file
could be the result of encrypting the message on the second line, or ‘NO’ in the other case.
Sample Input
JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES
Sample Output
YES
NO
YES
YES
NO
代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<ctype.h>
char s[107],s1[107];
int a[107],a1[107];
int main()
{
int i,k,j,t;
while(scanf("%s%s",s,s1)!=EOF)
{
for(i=0;i<strlen(s);i++)
a[s[i]-‘A’]++;
for(i=0;i<strlen(s1);i++)
a1[s1[i]-‘A’]++;
for(i=0;i<25;i++)
for(j=i+1;j<26;j++)
{
if(a[i]>a[j])
{
t=a[i];
a[i]=a[j];
a[j]=t;
}
if(a1[i]>a1[j])
{
t=a1[i];
a1[i]=a1[j];
a1[j]=t;
}
}
k=0;
for(i=0;i<26;i++)
if(a[i]!=a1[i])
{
k=1;
break;
}
if(k0)
printf(“YES\n”);
else
printf(“NO\n”);
memset(s,0,sizeof(s));
memset(s1,0,sizeof(s1));
memset(a,0,sizeof(a));
memset(a1,0,sizeof(a1));
}
return 0;
}
代码2:快速排序
利用此题体会快排用法(qsort)C语言
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<ctype.h>
char s[107],s1[107];
int a[107],a1[107];
int cmp(const void *x, const void *y)
{
return *(int *)x - *(int *)y;
}
int main()
{
int i,k;
while(scanf("%s%s",s,s1)!=EOF)
{
for(i=0;i<strlen(s);i++)
a[s[i]-‘A’]++;
for(i=0;i<strlen(s1);i++)
a1[s1[i]-‘A’]++;
qsort(a,26,sizeof(a[0]),cmp);
qsort(a1,26,sizeof(a1[0]),cmp);
k=0;
for(i=0;i<26;i++)
if(a[i]!=a1[i])
{
k=1;
break;
}
if(k
0)
printf(“YES\n”);
else
printf(“NO\n”);
memset(s,0,sizeof(s));
memset(s1,0,sizeof(s1));
memset(a,0,sizeof(a));
memset(a1,0,sizeof(a1));
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/86299265