Poj1459 Power Network 预流推进

Poj1459 Power Network 预流推进

问题描述:

A power network consists of nodes (power stations, consumers and
dispatchers) connected by power transport lines. A node u may be
supplied with an amount s(u) >= 0 of power, may produce an amount 0
<= p(u) <= p
max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c
max(u)) of power, and may deliver an amount
d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0
for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any
dispatcher. There is at most one power transport line (u,v) from a node u
to a node v in the net; it transports an amount 0 <= l(u,v) <= l
max(u,v) of power delivered by u to v. Let Con=Σ
uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.
img

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p
max(u)=y. The label x/y of consumer u shows that c(u)=x and c
max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l
max(u,v)=y. The power consumed is Con=6. Notice that
there are other possible states of the network but the value of Con
cannot exceed 6.

Input

​ There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

​ For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample output

15

6

分析:

​ 本题可以采用网络最大流的模型来求解网络最大流需要一个源点和汇点,而原图中的电站,调度站和消费者结点都不能作为源点和汇点,因此在原图的基础上添加一个源点和汇点,顶点序号为n+1和n+2。

​ 引入源点和汇点后,对于每个电站,从源点引一条容量为pmax的弧;从每个消费者,引一条容量为cmax的弧到汇点;对于题目中的三元组(u,v)z.从顶点u连一条容量为z 的弧到顶点v。这样每个消费者实际消费的电流量流入汇点,源点提供的最大电流量就是每个电站pmax之和。

​ 下面直接求解最大流即可,这里使用的是预流推进的方法。

#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
const int maxn = 110;
const int maxf = 0x7fffffff;
int n,np,nc,m;
int resi[maxn][maxn];
deque<int> act;
int h[maxn];
int ef[maxn];
int s,t,V;
void push_relabel() {
    int sum = 0;
    int u,v,p;
    for(int i = 1;i <= V;i++) h[i] = 0;
    h[s] = V;
    memset(ef,0,sizeof(ef));
    ef[s] = maxf;ef[t] = -maxf;
    act.push_front(s);
    while(!act.empty()) {
        u = act.back();
        act.pop_back();
        for(int i = 1;i <= V;i++) {
            v = i;
            if(resi[u][v] < ef[u]) p = resi[u][v];
            else p = ef[u];
            if(p > 0 && (u == s || h[u] == h[v] + 1)) {
                resi[u][v]-=p;resi[v][u]+=p;
                if(v == t) sum+=p;
                ef[u]-=p;ef[v]+=p;
                if(v != s && v != t) act.push_front(v);
            }
        }
        if(u != s && u != t && ef[u] > 0) {
            h[u]++;
            act.push_front(u);
        }
    } 
    printf("%d\n",sum);
}
int main() {
    int u,v,val;
    while(scanf("%d%d%d%d",&n,&np,&nc,&m) != EOF) {
        s = n + 1;t = n + 2;V =  n+2;
        memset(resi,0,sizeof(resi));
        for(int i = 0;i < m;i++) {
            while(getchar() != '(');
            scanf("%d,%d)%d",&u,&v,&val);
            resi[u+1][v+1] = val;
        }
        for(int i = 0;i < np;i++) {
            while(getchar() != '(');
            scanf("%d)%d",&u,&val);
            resi[s][u+1] = val;
        }    
        for(int i = 0;i < nc;i++) {
            while(getchar() != '(');
            scanf("%d)%d",&u,&val);
            resi[u+1][t] = val;
        }
        push_relabel();
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/pot-a-to/p/10959986.html