【Power Network】【POJ - 1459】(网络流-最大流)

版权声明:本人原创,未经许可,不得转载 https://blog.csdn.net/qq_42505741/article/details/84451523

题目:

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 


An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

解题报告:

题目的意思很明确,是有n个点,有np个发电场,nc个用户,有m条电路。最大网络流的问题,增加一个源点和汇点,之后就可以转化为最大流的问题求解。,套模板,输入的时候进行了优化(修改自kuangbin大大的模板---这里)。

ac代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
typedef long long ll;

const int maxn=110;
const int inf =0x7fffffff;
int mp[maxn][maxn],path[maxn],flow[maxn],start,end;
int n;
queue<int > q;
int bfs()
{
	int i,t;
	while(!q.empty()) q.pop();//清空队列 
	memset(path,-1,sizeof(path));
	path[start]=0;
	flow[start]=inf;
	q.push(start);
	while(!q.empty())
	{
		t=q.front();
		q.pop();
		if(t==end) break;
		for(i=0;i<=n;i++)
		{
			if(i!=start&&path[i]==-1&&mp[t][i])
			{
				flow[i]=flow[t]<mp[t][i]? flow[t]:mp[t][i];
				q.push(i);
				path[i]=t; 
			}
		}
	}
	if(path[end]==-1) 
		return -1;
	return flow[n];//最小的路径承载力 
	 
}
int EK()
{
	int max_flow=0;
	int step,now,pre;
	while((step=bfs())!=-1)
	{
		max_flow+=step;
		now=end;
		while(now!=start)
		{
			pre=path[now];
			mp[pre][now]-=step;
			mp[now][pre]+=step;
			now=pre;
		}//倒退回去,满足网络流的三条特性 
	}
	return max_flow;//嘴的的输出量 
}
int main()
{
	int i,u,v,z,np,nc,m;
	while(scanf("%d%d%d%d",&n,&np,&nc,&m)!=EOF)
	{
		memset(mp,0,sizeof(mp));//建图 
		while(m--)
		{
			while(getchar()!='(');
			scanf("%d,%d)%d",&u,&v,&z);
			u++;
			v++;
			mp[u][v]=z;
		}
		while(np--)
		{
			while(getchar()!='(');
			scanf("%d)%d",&u,&z);
			u++;
			mp[0][u]=z;
		}
		while(nc--)
		{
			while(getchar()!='(');
			scanf("%d)%d",&u,&z);
			u++;
			mp[u][n+1]=z;
		}//建图完毕 
		n++;//虚结点的设立,汇点 
		start=0;
		end=n;
		printf("%d\n",EK());
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42505741/article/details/84451523