算法_hdoj_1005

Question:

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 56626    Accepted Submission(s): 26273

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 
Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the maximum according to rules, and one line one case.
 
Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 
Sample Output
4 10 3
 
Author
lcy
 
idea:
first create two arrays to saving the input data,one is data that use to saving the input data and it won't change anyway,the other one is result that storing the input data and will change every circle,it will store the sum of a increasing sub-sequence before this kont in the last, which every element is smaller than it.
it's a simply DP
 
translate in chinese:
定义两个数组,第一个数组是data,用来存储输入的信息,他不会改变,只允许被访问
另外一个数组是result,用来存储第一个节点到每一个节点的递增子序列的和,最后这个数组里存储的都是第一个节点到指定节点的递增子序列的和
然后通过遍历result数组就可以得到最大递增子序列
View Code

source code:

import java.util.Scanner;

/**
 * 3 1 3 2
 * 4 1 2 3 4
 * 4 3 3 2 1
 * 0
 */
public class Main {
    static Scanner sc = new Scanner(System.in);
    public static void main(String[] args) {
       while(true){
           int ammount = sc.nextInt();
           if(ammount==0)break;
           int[] data = new int[ammount];
           int[] result = new int[ammount];

           for(int i = 0;i < ammount;i++){
               data[i] = sc.nextInt();
               result[i] = data[i];
           }

           /**
            * 思想:从data数组的第一项到每一项查看,从第一项开始,如果此项比指定项小,就加上,然后进行下一项
            */
           for(int i = 1;i < data.length;i++){
               for(int j = 0;j < i;j++){
                   if(data[j] < data[i])result[i] = Math.max(result[i],result[j]+data[i]);
               }
           }
           int ans = -99;
           for(int temp:result){
               if(temp > ans)ans = temp;
           }
           System.out.println(ans);
       }
    }
}

hope that I can help you 

that's all

 
 

猜你喜欢

转载自www.cnblogs.com/lavender-pansy/p/10940866.html