c 打印斐波那契数列第n个数

Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.

Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.

Output
Print out the answer in a single line for each test case.

Sample Input
3
4
5
-1

Sample Output
2
3
5

题目英文直接代码

#include<stdio.h>
void main()
{
    int n,i;
	_int64 a[51] = {0,1,1,2};
	for(i=4;i<51;i++){
		a[i] = a[i-1] + a[i-2];
	}
    while(scanf("%d",&n)&&n!=-1)
    {
        printf("%I64d\n",a[n]);
    }
}


猜你喜欢

转载自blog.csdn.net/qq_40811682/article/details/88343287