lightoj1058计算几何

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

Input starts with an integer T (≤ 15), denoting the number of test cases.

The first line of each test case contains an integer n (1 ≤ n ≤ 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

For each case, print the case number and the number of parallelograms that can be formed.

Sample Input

2

6

0 0

2 0

4 0

1 1

3 1

5 1

7

-2 -1

8 9

5 7

1 1

4 8

2 0

9 8

Sample Output

Case 1: 5

Case 2: 6

#include<iostream>
#include<cstdio>
#include<algorithm>
#define maxn 1200
#define maxm 1000005
#define ll long long
using namespace std;
int t;
int n;
int cnt;
struct node
{
    ll x,y;
}node1[maxn],node2[maxm];
bool cmp(node a,node b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int main()
{
    scanf("%d",&t);
    int w=0;
    while(t--)
    {w++;
    cnt=0;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        {scanf("%lld%lld",&node1[i].x,&node1[i].y);


    }
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
    {
        node2[++cnt].x=node1[i].x+node1[j].x;
        node2[cnt].y=node1[i].y+node1[j].y;
    }
    sort(node2+1,node2+cnt+1,cmp);
    ll ans=1,sum=0;
    for(int i=1;i<cnt;i++)
        {if(node2[i].x==node2[i+1].x&&node2[i].y==node2[i+1].y)
        ++ans;
        else
        {sum+=(ans-1)*ans/2;
        ans=1;

        }
        }
        printf("Case %d: %lld\n",w,sum);
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89930517