HDU 1299 Diophantus of Alexandria

版权声明:如果转载,请注明出处。 https://blog.csdn.net/S_999999/article/details/89437436

Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3959    Accepted Submission(s): 1567


 

Problem Description

Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles.

Consider the following diophantine equation: 

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)



Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions: 

1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4




Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?

 

Input

The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9). 

 

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line. 

 

Sample Input

 

2

4

1260

Sample Output

Scenario #1: 3

Scenario #2: 113

直接枚举会超时,这是会用到 算数基本定理,也就是(唯一分解定理).

算术基本定理:

每个大于1的正整数N都可以表示成素数之积的形式 :

 N=p1^a1*p2^a2*p3^a3...(pi代表素数,ai代表指数)

d(n)是n的正因子的个数:

                                d(n)=(a1+1)*(a2+1)*(a3+1)…

 


 

#include<iostream>
#include<cmath>
using namespace std;
long  long solve(int n){
      long long ans=1;
      int i;
      int m=(int)sqrt(n+0.5);
      for(i=2;i<=m;i++){
          int ret=1; 
          if(n%i==0){
             n/=i;
             while(n%i==0){
                n/=i;
				ret++;
            }
            ans*=(2*ret+1);
        }
        if( n<i ) 
		    break;
    }
    if( n>1 ) { 
	    ans*=3; // n为素数素数时
	}
    return ans;
}
int main(void)
{
    int n;
    int cas=1,t;
    scanf("%d",&t);
    while(t--){ 
        scanf("%d",&n);
        printf("Scenario #%d:\n%lld\n",cas++,solve(n)/2+1);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/S_999999/article/details/89437436