B-number (数位dp)

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9840    Accepted Submission(s): 5893


 

Problem Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

 

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

 

Output

Print each answer in a single line.

 

Sample Input

 

13 100 200 1000

 

Sample Output

 

1 1 2 2

 

Author

wqb0039

 

Source

2010 Asia Regional Chengdu Site —— Online Contest

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define ll long long
ll dp[30][30][3], a[100];
ll pos, r, t;

ll dfs(int pos, int mod, int state, bool limit) {
    if (pos == -1) return (mod == 0 && state == 2);
    if (!limit && dp[pos][mod][state] != -1) return dp[pos][mod][state];
    int up = limit ? a[pos] : 9;
    int ans = 0;
    for (int i = 0; i <= up; i++) {
        int temp = 0;
        if (state == 2 || (state == 1 && i == 3)) temp = 2;
        else if (i == 1) temp = 1;
        ans += dfs(pos - 1, (mod * 10 + i) % 13, temp, limit && i == a[pos]);
    }
    if (!limit) dp[pos][mod][state] = ans;
    return ans;
}

ll solve(ll x) {
    pos = 0;
    while (x) {
        a[pos++] = x % 10;
        x /= 10;
    }
    return dfs(pos - 1, 0, 0, true);
}

int main() {
    memset(dp, -1, sizeof(dp));
    while (scanf("%d", &t) != EOF) {
        printf("%lld\n", solve(t));
    }
    return 0;
}

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  3651 3655 3654 3653 3659 

猜你喜欢

转载自blog.csdn.net/LanQiLi/article/details/89636289