poj3250 Bad Hair Day 单调栈(递减)

Bad Hair Day

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 24420   Accepted: 8292

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c 1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

题意:有一群牛站成一排,每头牛都是面朝右的,每头牛可以看到他右边身高比他小的牛。给出每头牛的身高,要求每头牛能看到的牛的总数

//单调递减栈
#include<iostream>
#define ll long long
#include<stack>
using namespace std;
stack<ll>p;     //栈里面存的是下标
ll a[100005];
ll n,ans;
int main()
{
    while(~scanf("%lld",&n))
    {
        while(!p.empty())
            p.pop();
        for(int i=0;i<n;i++)
            scanf("%lld",&a[i]);
        a[n]=999999999999999;//为找比a[n-1]大的数准备
        ans=0;
        for(int i=0;i<=n;i++)
        {
            if(p.empty()||a[i]<a[p.top()])//符合严格单调递减规则,入栈
                p.push(i);
            else
            {
                while(!p.empty()&&a[i]>=a[p.top()])//找到第一个不小于栈顶元素的数的下标
                {
                    ll top;
                    top=p.top();
                    p.pop();
                    ans=ans+(i-top-1);//这个数到第一个不小于这个数之间的数都是比这个数小,开区间
                }
                //如果a[i]可以使当前栈严格单调递减,入栈
                p.push(i);
            }
        }
        printf("%lld\n",ans);
    }
    return 0;

}

猜你喜欢

转载自www.cnblogs.com/-citywall123/p/10769634.html
今日推荐