Bad Hair Day ——牛说我瞅你咋地——单调栈POJ3250

                                                   Bad Hair Day 

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c 1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

题意:一群牛往右看(大概右边有妹子 ?_? ),每头牛可以看见右边比他矮的,如果比他矮的牛,被比他高的牛挡到了,显然他看不见。 所以求这些牛一共能看见多少牛? 

注意: 一样高的他也看不见。

第一感觉是单调栈,然后逆向思维一下,对于每头牛应该考虑他被多少头牛看见,然后建一个从左往右的单调减栈,得到答案;

题意转换成   每头牛能被在他左边比他矮的看见 应该才是突破;

我也不明白 int为什么会WA,,,

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <stack>
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int maxn=2e6+7;
int n,m;
int main()
{
    int t;
    while(scanf("%d",&n)!=EOF&&n)
    {
        unsigned long long  cnt=0;
        for(int i=1;i<=n;++i)
            scanf("%d",&a[i]);
        stack<int> st;
        ///构造一个单调减的栈   从右往左
        for(int i=1;i<=n;++i)
        {
            while(!st.empty()&&a[i]>=st.top())
            {
                st.pop();
            }
            cnt+=st.size();
            st.push(a[i]);
        }
        cout<<cnt<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codetypeman/article/details/81515201