HDU - 5542 The Battle of Chibi(树状数组+DP+离散化)(第一节ccpc 南阳)

Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao Cao's army. But all generals and soldiers of Cao Cao were loyal, it's impossible to convince any of them to betray Cao Cao. 

So there is only one way left for Yu Zhou, send someone to fake surrender Cao Cao. Gai Huang was selected for this important mission. However, Cao Cao was not easy to believe others, so Gai Huang must leak some important information to Cao Cao before surrendering. 

Yu Zhou discussed with Gai Huang and worked out NN information to be leaked, in happening order. Each of the information was estimated to has aiai value in Cao Cao's opinion. 

Actually, if you leak information with strict increasing value could accelerate making Cao Cao believe you. So Gai Huang decided to leak exact MM information with strict increasing value in happening order. In other words, Gai Huang will not change the order of the NN information and just select MM of them. Find out how many ways Gai Huang could do this.

Input

The first line of the input gives the number of test cases, T(1≤100)T(1≤100). TT test cases follow. 

Each test case begins with two numbers N(1≤N≤103)N(1≤N≤103) and M(1≤M≤N)M(1≤M≤N), indicating the number of information and number of information Gai Huang will select. Then NN numbers in a line, the ithith number ai(1≤ai≤109)ai(1≤ai≤109) indicates the value in Cao Cao's opinion of the ithith information in happening order.

Output

For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 1) and yy is the ways Gai Huang can select the information. 

The result is too large, and you need to output the result mod by 1000000007(109+7)1000000007(109+7).

Sample Input

2
3 2
1 2 3
3 2
3 2 1

Sample Output

Case #1: 3
Case #2: 0

Hint

In the first cases, Gai Huang need to leak 2 information out of 3. He could leak any 2 information as all the information value are in increasing order. 
In the second cases, Gai Huang has no choice as selecting any 2 information is not in increasing order.

 思路:dp[i][j],表示到第i个数字,长度为j的单调递增子序列的个数。需要注意的是取第j个数字。

#include <cstdio>
#include <queue>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <map>
#include <set>
#include <bitset>
#include <stack>
#define ll long long
#define ull unsigned long long
#define inf 0x3f3f3f3f
const int mod=1000000007;
const int N=1010;
using namespace std;
int dp[N][N];
int num[N];
int n,m;

int main()
{
int t,case=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&num[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            dp[i][1]=1;
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=min(i,m); j++)
            {
                for(int k=1; k<i; k++)
                {
                    if(num[k] <= num[i])
                    {
                        dp[i][j]=(dp[k][j-1]+dp[i][j])%mod;
                    }
                }
            }
        }
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            ans=(ans+dp[i][m])%mod;
        }
        printf("Case #%d: ",++cas);
        printf("%d\n",ans);
    }


    return 0;
}

n^3的复杂度会超时。利用树状数组优化第三层循环。

#include <cstdio>
#include <queue>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <map>
#include <set>
#include <bitset>
#include <stack>
#define ll long long
#define ull unsigned long long
#define inf 0x3f3f3f3f
const int mod=1000000007;
const int N=1010;
using namespace std;
int dp[N][N];
int num[N];
int b[N];
int n,m;
int lowbit(int x)
{
    return x&(-x);
}
int sum(int x,int y)
{
    int ret=0;
    while(x>0)
    {
        ret=(ret+dp[x][y])%mod;
        x-=lowbit(x);
    }
    return ret;
}
void add(int x,int y,int d)
{
    while(x<=n)
    {
        dp[x][y]=(dp[x][y]+d)%mod;
        x+=lowbit(x);
    }
}
int main()
{
    int t;
    int cnt=1;
    scanf("%d",&t);
    while(t--)
    {

        scanf("%d%d",&n,&m);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&num[i]);
            b[i]=num[i];
        }
        sort(b+1,b+1+n);
        for(int i=1; i<=n; i++)
        {
            //求在原数组内是第几大
            num[i]=lower_bound(b+1,b+1+n,num[i])-b;
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=min(i,m); j++) //长度
            {
                if(j==1)
                    add(num[i],1,1);
                else
                {
                    //求前面长度为j-1,并且满足上升的序列个数和
                    int p=sum(num[i]-1,j-1);
                    add(num[i],j,p);//把dp[num[i]][j]插入到数组里面
                }
            }
        }
        printf("Case #%d: %d\n",cnt++,sum(n,m));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Kuguotao/article/details/89351754