HDU - 5542 The Battle of Chibi (DP + 离散化+树状数组)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/89349260

The Battle of Chibi

Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao Cao's army. But all generals and soldiers of Cao Cao were loyal, it's impossible to convince any of them to betray Cao Cao. 

So there is only one way left for Yu Zhou, send someone to fake surrender Cao Cao. Gai Huang was selected for this important mission. However, Cao Cao was not easy to believe others, so Gai Huang must leak some important information to Cao Cao before surrendering. 

Yu Zhou discussed with Gai Huang and worked out NN information to be leaked, in happening order. Each of the information was estimated to has aiai value in Cao Cao's opinion. 

Actually, if you leak information with strict increasing value could accelerate making Cao Cao believe you. So Gai Huang decided to leak exact MM information with strict increasing value in happening order. In other words, Gai Huang will not change the order of the NN information and just select MM of them. Find out how many ways Gai Huang could do this.

Input

The first line of the input gives the number of test cases, T(1≤100)T(1≤100). TT test cases follow. 

Each test case begins with two numbers N(1≤N≤103)N(1≤N≤103) and M(1≤M≤N)M(1≤M≤N), indicating the number of information and number of information Gai Huang will select. Then NN numbers in a line, the ithith number ai(1≤ai≤109)ai(1≤ai≤109) indicates the value in Cao Cao's opinion of the ithith information in happening order.

Output

For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 1) and yy is the ways Gai Huang can select the information. 

The result is too large, and you need to output the result mod by 1000000007(109+7)1000000007(109+7).

Sample Input

2
3 2
1 2 3
3 2
3 2 1

Sample Output

Case #1: 3
Case #2: 0

        
  

Hint

In the first cases, Gai Huang need to leak 2 information out of 3. He could leak any 2 information as all the information value are in increasing order. 
In the second cases, Gai Huang has no choice as selecting any 2 information is not in increasing order.

题目大意:给出长度为n的数列,求其中长度为m的严格单调递增子序列有多少个

思路:dp [ i ] [ j ]  指数列的前 i 个数中,长度为 j 的递增子序列的个数 ,并且约束a[i]一定是子序列的最后一个数

状态转移的过程:

for(int i=1;i<=n;i++)
    for(int j=1;j<=min(m,i+1);j++)
    {
        if(j==1) dp[i][j]=1;
        else
        for(int k=i-1;k>=1;k--)
            if(a[k]<a[i])
            dp[i][j]=(dp[i][j]+dp[k][j-1])%mod;
    }

但是n^3会超时,所以可以用树状数组优化第三层的for循环

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=1010;
const int mod=1e9+7;
int a[N],b[N],dp[N][N],n,m;
void add(int x,int y,int d)//更新
{
    while(x<=n)
    {
        dp[x][y]=(dp[x][y]+d)%mod;
        x+=(x&-x);
    }
}
int sum(int x,int y) //求和
{
    int tmp=0;
    while(x>0)
    {
        tmp=(tmp+dp[x][y])%mod;
        x-=(x&-x);
    }
    return tmp;
}
int main()
{
    int t=1,T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[i]=a[i];
        }
        sort(b+1,b+1+n);
        for(int i=1;i<=n;i++) //离散化 a[i]是该位置数在数列中的排序
            a[i]=lower_bound(b+1,b+1+n,a[i])-b;
        
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=min(i+1,m);j++)
        {
            if(j==1) add(a[i],1,1); //子序列长度为1的时候直接加一
            else
            {
                int tmp=sum(a[i]-1,j-1);  //tmp是当前 子序列长度为j-1且子序列最后一个数小于a[i]的子序列个数
                add(a[i],j,tmp); 
            }
        }
        printf("Case #%d: %d\n",t++,sum(n,m));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/89349260