ZOJ Battle Ships--DP

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases.
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5


Author: FU, Yujun
Contest: ZOJ Monthly, July 2012

Submit    Status


有n个塔和一个L血的怪物,制造一个塔需要t【i】时间,制造完成之后每秒对怪物造成L【i】血。问最少需要多少时间能消灭怪物。

#include<bits/stdc++.h>
using namespace std;
int t[1000];
int l[1000];
int dp[1000];
int main()
{
    int n,L;
    while(scanf("%d%d",&n,&L)!=EOF)
    {
        int i,j;
        for(i=1;i<=n;i++)
            cin>>t[i]>>l[i];
        memset(dp,0,sizeof(dp));
        for(j=1;j<=L;j++)
        {
            for(i=1;i<=n;i++)
            {
                dp[j+t[i]]=max(dp[j+t[i]],dp[j]+l[i]*j);

            }
        }
        for(i=1;i<=400;i++)
        {
            if(dp[i]>=L)
            {

                break;
            }
        }
        cout<<i<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/89045696