[动态规划]UVA437 - The Tower of Babylon


 The Tower of Babylon 

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions tex2html_wrap_inline32 . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values tex2html_wrap_inline40 , tex2html_wrap_inline42 and tex2html_wrap_inline44 .

Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:

也许你曾听过巴比伦塔的传说,如今这个故事的很多细节已经被遗忘了。如今,我们要告诉你整个故事:

巴比伦人有n种不同的积木。每种积木都是实心长方体。且数目都是无限的。

第i种积木的长宽高分别为{ i , y i , z i }。积木能够被旋转。所曾经面的长宽高是能够互相换的。

也就是当中2个组成底部的长方形,剩下的一个为高度。巴比伦人想要尽可能的用积木来堆高塔,可是两块积木要叠在一起是有条件的:仅仅有在第一块积木的底部2个边均小于第二块积木的底部相对的2个边时,第一块积木才干够叠在第二块积木上方。比如:底部为3x8的积木能够放在底部为4x10的积木上,可是无法放在底部为6x7的积木上。

给你一些积木的资料,你的任务是写一个程式算出能够堆出的塔最高是多少。

思路:最长上升连续子序列的题目,最重要的是建模的过程,由于积木能够翻转。所以有六种状态,之后对于每种状态排个序,预处理下。后面会省事非常多。

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

class Block
{
public:
    int x,y,z;
    void fun(int a,int b,int c)
        {
            x=a;
            y=b;
            z=c;
        }
}node[200];

bool cmp(Block r,Block t)
    {
        return r.x*r.y<t.x*t.y;
    }

int dp[200];

int main()
    {
        int num,cnt=0;
        while(cin>>num&&num)
            {
                int a,b,c;
                int m=0;
                for(int i=0;i<num;i++)
                    {
                        cin>>a>>b>>c;
                        node[m++].fun(a, b, c);
                        node[m++].fun(a, c, b);
                        node[m++].fun(b, a, c);
                        node[m++].fun(b, c, a);
                        node[m++].fun(c, a, b);
                        node[m++].fun(c, b, a);
                    }
                sort(node,node+m,cmp);
                int maxlen=0;
                memset(dp,0,sizeof(dp));
                for(int i=0;i<m;i++)
                    {
                        dp[i]=node[i].z;
                        for(int j=0;j<i;j++)
                            {
                                if(node[i].x>node[j].x&&node[i].y>node[j].y)
                                    {
                                        dp[i]=max(dp[i],dp[j]+node[i].z);
                                    }
                            }
                        if(dp[i]>maxlen) maxlen=dp[i];
                    }
                cout<<"Case "<<++cnt<<": maximum height = "<<maxlen<<endl;
            }
        return 0;
    }


猜你喜欢

转载自www.cnblogs.com/ldxsuanfa/p/10681706.html
今日推荐