HDU-5706(DFS)

题目链接:acm.hdu.edu.cn/showproblem.php?pid=5706
GirlCat
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1823 Accepted Submission(s): 1091

Problem Description

As a cute girl, Kotori likes playing Hide and Seek'' with cats particularly. Under the influence of Kotori, many girls and cats are playingHide and Seek’’ together.
Koroti shots a photo. The size of this photo is n×m, each pixel of the photo is a character of the lowercase(from a' toz’).
Kotori wants to know how many girls and how many cats are there in the photo.

We define a girl as – we choose a point as the start, passing by 4 different connected points continuously, and the four characters are exactly girl'' in the order. We define two girls are different if there is at least a point of the two girls are different. We define a cat as -- we choose a point as the start, passing by 3 different connected points continuously, and the three characters are exactlycat’’ in the order.
We define two cats are different if there is at least a point of the two cats are different.

Two points are regarded to be connected if and only if they share a common edge.

Input

The first line is an integer T which represents the case number.

As for each case, the first line are two integers n and m, which are the height and the width of the photo.
Then there are n lines followed, and there are m characters of each line, which are the the details of the photo.

It is guaranteed that:
T is about 50.
1≤n≤1000.
1≤m≤1000.
∑(n×m)≤2×106.

Output

As for each case, you need to output a single line.
There should be 2 integers in the line with a blank between them representing the number of girls and cats respectively.

Please make sure that there is no extra blank.

Sample Input

3
1 4
girl
2 3
oto
cat
3 4
girl
hrlt
hlca

Sample Output

1 0
0 2
4 1

题目大意:输入第一行表示多少个测试案例,然后跟着T组测试案例,每一组都先输入多少行,多少列。然后紧跟着就是n行m列字符。然后让你找这个图中有多少个girl和cat,比如girl你就从g字符开始从它的上下左右找i,找到i后,又从i的上下左右找r。一次如果能组成一个完整的girl就算一个。cat也是这样。

解题思路:

典型的dfs,bfs亦可。这里用的是dfs,用两个字符数组将girl和cat存起来,需要注意的是每次递归传值时,都要把字符数组的下标传进去,遍历四个方向时利用传进来的下标取字符串中的字符来比较。思路虽然简单,但还是要注意dfs的细节。

AC代码:

#include<cstdio>
int M[4][2] = {-1, 0, 1, 0, 0, 1, 0, -1};
char s1[] = "girl", s2[] = "cat";
char s[1010][1010];
int ans1, ans2;
int n, m;
void dfsgirl(int x, int y, int k)
{
    int dx, dy;
    for(int i = 0; i < 4; ++i)
    {
        dx = x + M[i][0];
        dy = y + M[i][1];
        if(dx >= 0 && dx < n && dy >= 0 && dy < m && s[dx][dy] == s1[k])
        {
            k++;
            if(k == 4)
            {
                ans1++;
            }
            dfsgirl(dx, dy, k);
            k--;
        }
    }
}

void dfscat(int x, int y, int k)
{
    int dx, dy;
    for(int i = 0; i < 4; ++i)
    {
        dx = x + M[i][0];
        dy = y + M[i][1];
        if(dx >= 0 && dx < n && dy >= 0 && dy < m && s[dx][dy] == s2[k])
        {
            k++;
            if(k == 3)
            {
                ans2++;
                k--;
            }
            else
            {
                dfscat(dx, dy, k);
                k--;
            }
        }
    }
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        ans1 = ans2 = 0;
        scanf("%d%d", &n, &m);
        for(int i = 0; i < n; ++i)
            scanf("%s", s[i]);

        for(int i = 0; i < n; ++i)
            for(int j = 0; j < m; ++j)
            {
                if(s[i][j] == 'g')
                {
                    dfsgirl(i, j, 1);
                }
                if(s[i][j] == 'c')
                {
                    dfscat(i, j, 1);
                }
            }
        printf("%d %d\n", ans1, ans2);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40739219/article/details/83757931