dfs HDU 1501

Problem Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input
3
cat tree tcraete
cat tree catrtee
cat tree cttaree
 

Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no

 题意:

 给你3个字符串A,B和C.问你由字符串A和B的字符能否构成C字符串.你可以任意组合A和B的字符,但是A中或B中所有字符间的相对位置不能改变.且C字符的个数=A字符个数+B字符个数.

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=205;
char A[maxn],B[maxn],C[maxn*2];  //错误1,这里C的数组是两倍长度
bool vis[maxn][maxn];            //vis数组用来标记我们之前是否考虑过a,b的情况
bool dfs(int c,int a,int b)
{
    if(C[c]==0) return true;
    if(vis[a][b]) return false;
    vis[a][b]=1;
    if(C[c]==A[a])
    {
        if(dfs(c+1,a+1,b)) return true;
    }
    if(C[c]==B[b])
    {
        if(dfs(c+1,a,b+1)) return true;
    }
    return false;
}
int main()
{
    int T; scanf("%d",&T);
    for(int kase=1;kase<=T;kase++)
    {
        memset(vis,0,sizeof(vis));
        scanf("%s%s%s",A,B,C);
        if(dfs(0,0,0)) printf("Data set %d: yes\n",kase);
        else printf("Data set %d: no\n",kase);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40859951/article/details/84572139