Dijkstra 记个模板 >>Silver Cow Party

Silver Cow Party

 One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意

n个农场n个奶牛,x是开派对的地方,求每个奶牛到x的最短路的最大值。

第一时间想到把每个农场到x的最短路和x到他们自己农场的最短路都算一遍,结果肯定是超时了。

发现每个农场到x的最短路就是x到每个农场的最短路,但因为路是单向的,所以往回走的时候把所有路的双向的时间换一下,(即原本1->2=1 , 2->1=2 变为1->2=2, 2->1=1)再算一遍x到所有农场的最短路就好。

还有inf定的无穷大要大,不然就会wa = =!

#include <iostream>
#include <string.h>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include <map>
#include<set>
#include<cstdio>
#include<vector>
#include<list>
#include<time.h>
#include<bitset>
using namespace std;
int e[1005][1005];
int dis[1005];
int dis2[1005];
int book[1005];
int inf=9999999;
int n,m,x;
int main()
{
    scanf("%d %d %d",&n,&m,&x);
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
        {
            if(i==j)
                e[i][j]=0;
            else
                e[i][j]=inf;
        }
    }

    for(int i=0; i<m; i++)
    {
        int a,b,c;
        scanf("%d %d %d",&a,&b,&c);
        e[a][b]=c;
    }

    memset(book,0,sizeof(book));

    for(int i=1; i<=n; i++)
    {
        dis[i]=e[x][i];
    }
    book[x]=1;

    for(int i=0; i<n-1; i++)
    {
        int mi=inf;
        int u;
        for(int j=1; j<=n; j++)
        {
            if(!book[j]&&dis[j]<mi)
            {
                mi=dis[j];
                u=j;
            }
        }
        book[u]=1;
        for(int j=1; j<=n; j++)
        {
            if(e[u][j]<inf)
            {
                if(dis[j]>dis[u]+e[u][j])
                    dis[j]=dis[u]+e[u][j];
            }
        }
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<i;j++)
        {
            int mm=e[i][j];
            e[i][j]=e[j][i];
            e[j][i]=mm;
        }
    }

    memset(book,0,sizeof(book));
    for(int i=1; i<=n; i++)
    {
        dis2[i]=e[x][i];
    }
    book[x]=1;

    for(int i=0; i<n-1; i++)
    {
        int mi=inf;
        int u;
        for(int j=1; j<=n; j++)
        {
            if(!book[j]&&dis2[j]<mi)
            {
                mi=dis2[j];
                u=j;
            }
        }
        book[u]=1;
        for(int j=1; j<=n; j++)
        {
            if(e[u][j]<inf)
            {
                if(dis2[j]>dis2[u]+e[u][j])
                    dis2[j]=dis2[u]+e[u][j];
            }
        }
    }
    int ma=0;
    for(int i=1;i<=n;i++)
    {
        ma=max(ma,dis[i]+dis2[i]);
    }
    printf("%d\n",ma);
}

猜你喜欢

转载自blog.csdn.net/qq_43372531/article/details/88806199