Dijkstra算法模板(POJ 3268)很好的理解题 Silver Cow Party

Silver Cow Party
Time Limit: 2000MS

Memory Limit: 65536K
Total Submissions: 29507

Accepted: 13395
Description
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
这个题目主要是讲解了dijkstra算法的使用。本人感觉这种算法用优先队列的优化并不是很好,并没有太大的改观。所以我就写了一个很普通的算法,适合用于规范形式。
用了两次基本相同dijkstra算法

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define maxn 1010
int map[maxn][maxn],n;
int dis[maxn];
int result[maxn];

//正向的disjkstra算法
void dijkstra(int x)
{
    int visit[maxn],i,j,min,next=x;
    memset(visit,0,sizeof(visit));
    for(i=1;i<=n;++i)
        dis[i]=map[x][i];
    visit[x]=1;
    for(i=2;i<=n;++i)
    {
        min=INF;
        for(j=1;j<=n;++j)
        {
            if(!visit[j]&&dis[j]<min)
            {
                min=dis[j];
                next=j;
            }
        }
        visit[next]=1;
        result[next]+=min;
        for(j=1;j<=n;++j)
        {
            if(!visit[j]&&dis[j]>dis[next]+map[next][j])
                dis[j]=dis[next]+map[next][j];
        }
    }
}

//反向的dijkstra算法
void dijkstra2(int x)
{
    int visit[maxn],i,j,min,next=x;
    memset(visit,0,sizeof(visit));
    for(i=1;i<=n;++i)
        dis[i]=map[i][x];
    visit[x]=1;
    for(i=2;i<=n;++i)
    {
        min=INF;
        for(j=1;j<=n;++j)
        {
            if(!visit[j]&&dis[j]<min)
            {
                min=dis[j];
                next=j;
            }
        }
        visit[next]=1;
        result[next]+=min;
        for(j=1;j<=n;++j)
        {
            if(!visit[j]&&dis[j]>dis[next]+map[j][next])
                dis[j]=dis[next]+map[j][next];
        }
    }
}



int main()
{
    int m,x,i,j,a,b,t;
    while(scanf("%d%d%d",&n,&m,&x)!=EOF)
    {
        memset(result,0,sizeof(result));
        for(i=1;i<=n;++i)
        {
            for(j=1;j<=n;++j)
            {
                if(i!=j)
                    map[i][j]=INF;
                else
                    map[i][j]=0;
            }
        }
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&t);
            if(t<map[a][b])
                map[a][b]=t;
        }

        dijkstra(x);
        dijkstra2(x);
        //实现最短路径

        int ans = -1;
        for(i=1;i<=n;++i)
        {
            if(i!=x)
                ans=max(ans,result[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40488730/article/details/82354401